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1 About the Extension Satellite Orbit Propagation 

The GAFmap® extension Satellite Orbit Propagation provides additional functions in 

GAFmap® for forecasting satellite positions/orbits and their visualization. This allows you, for 

example, to predict whether overflights of certain satellites are to be expected in the following 

hours or days for a certain target point on the earth's surface, and how well and with what 

quality (e.g. regarding viewing angle, resolution, etc.) they cover the target point. This way 

you can, for example, evaluate whether images of a certain quality might be available during 

the prediction period. 

 

The functions for the satellite orbit propagation are fully integrated in GAFmap®. To make 

them visible/available in the user interface, the extension Satellite Orbit Propagation has to 

be enabled under menu Extras > Extensions. An additional Satellite Orbit Propagation toolbar 

then appears, via which the satellite orbit propagation can be started (see chapter 3.1).  

 

If your GAFmap® license includes the 3D Viewer extension, the viewing perspective and/or 

overflight of satellites can also be visualized in 3D. Without 3D Viewer extension, only a 2D 

visualization is possible.  
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2 About this Manual 

This manual only covers the specific functions of the extension Satellite Orbit Propagation. 

Information on GAFmap® in general and the (standard) functions contained in the core com-

ponent of the software can be found in the GAFmap® Manual, information on the 3D compo-

nent in the GAFmap® 3D Viewer Manual.  

The structure of the manual is based on the arrangement of the functions in the user interface. 

The location of the described function in GAFmap® is noted in the corresponding chapter di-

rectly under the heading, e.g. 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer 

If a certain extension must be activated for a function to be available/visible in the user inter-

face, this is also noted at the top of the corresponding manual chapter, e.g.: 

[Menu Extras > Extensions > Satellite Orbit Propagation] 

or  

[Menu Extras > Extensions > 3D Viewer] 

Please note that the 3D Viewer extension is only available if it is included in your GAFmap® 

license. Without a 3D Viewer license, functions marked this way are not available. 
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3 About Satellite Orbit Propagation 

3.1 Starting the Satellite Orbit Propagation 

[Menu Extras > Extensions > Satellite Orbit Propagation] 

You can start the satellite orbit propagation by activating the button Add SOP Target Layer in 

the Satellite Orbit Propagation toolbar, setting a target point in the map viewer, and selecting 

the satellites to be analyzed (see chapter 4.1). A new so-called SOP Target Layer is then crea-

ted which, in addition to the target point itself, shows the expected overflight paths of the 

selected satellites calculated for this target point and the resulting potential acquisition strip 

(swath) covering the target point (see chapter 5.1). 

By default, the prediction is based on current TLEs from NORAD (see chapter 3.2) and is made 

for three days ahead. The potential viewing area of the satellites is taken into account; other-

wise, the result is unfiltered. The satellite selection, data source, prediction period, filter set-

tings, display options (symbology), etc. can be subsequently adjusted via the SOP target layer's 

properties (see chapter 5.1.11 et seqq.). Information on the satellites and the geometric rela-

tionships between satellite and target point is stored in an attribute table (see chapter 5.1.5 

and 5.1.6). 

For the SOP target layer, various functions are then available for visualization and analysis in 

2D and (with a corresponding GAFmap® license) also in 3D, e.g. a visualization as SkyPlot inclu-

ding terrain obstructions or a 3D simulation of the satellite's viewing angle and/or overflight. 

Information on the available functions and visualization options can be found in chapters 5 

and 6. 

Tips and notes: 

• See chapter 3.2 for more information if you receive an error massage when setting the 

target point. 

 

3.2 Data Source (TLEs) 

The satellite orbit propagation is based on TLE sets (Two-Line Orbital Element Sets), such as 

those provided by NORAD (North American Aerospace Defense Command). These are simple 

text files that contain relevant satellite orbital elements (shape of the orbit, position in space, 

time reference) as well as various correction parameters for determining the satellite orbit in 

standardized form (two lines each): 
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Figure 1: Excerpt from a TLE file (with examples for GeoEye-1, Landsat 8 and Sentinel-2A) 

On the basis of such TLEs, satellite positions/orbits can be calculated in advance for a specific 

time period. 

By default, the GAFmap® satellite orbit propagation uses TLEs from NORAD. They are provided 

for various satellites (for earth observation, navigation, communication, etc.) and are continu-

ously updated. To ensure that the data is up-to-date, it is retrieved directly from CelesTrak 

(http://www.celestrak.com/NORAD/elements/), which means that by default network access 

including access authorization to the URL mentioned is required (see also tips and notes be-

low). However, you can also use other TLEs, e.g. TLEs from other sources and/or locally stored 

TLE files. 

If the default source URL cannot be accessed when creating the SOP target layer, you receive 

an error message, e.g.: 

 

Figure 2: Error message if no if there is no connection to the CelesTrack.URL when setting the target point 

An empty SOP target layer is then created. Satellites can be added subsequently to the layer. 

For more information on how to add satellites subsequently, e.g. satellites that do not appear 

in the standard selection list and/or satellites from other data sources, see chapter 5.1.11.1.1.  

http://www.celestrak.com/NORAD/elements/
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Tips and notes: 

• If you want to use the default GAFmap® satellite orbit propagation, you need access to 

https://celestrak.org/. Test in advance in your Internet browser whether you can call 

up the URL mentioned. If not, the page may be blocked by your firewall!  

Check your proxy settings (see GAFmap® manual, chapter 3.5.1.13) if access only fails 

in GAFmap® but is otherwise possible. 

 

3.3 Accuracy and Timeliness 

Satellites are subject to various disturbances on their orbit around the earth, e.g. caused by 

the earth's irregular gravitational field, the moon's gravitational pull, solar winds, the resis-

tance of the earth's atmosphere, etc. These orbital disturbances cause satellite orbits to 

change continuously and unpredictably. A calculated prediction must therefore be continu-

ously compared and updated with actual observations, e.g. from tracking stations on Earth 

(see e.g. Wikipedia - Orbital elements). 

The TLEs on which the satellite orbit propagation in GAFmap® is based (see chapter 3.2) are 

snapshots of satellite orbits at a specific point in time ("epoch"). They contain all relevant 

orbital elements for the satellites included and also take the effects of orbital disturbances 

into account. The prediction of orbital perturbations is based on the SGP4 model (Simplified 

General Perturbations Model No. 4). The error of the model is about 1 km at epoch and in-

creases by approx. 1-3 km per day. For reasons of accuracy, the prediction should therefore 

not deviate from the epoch, i.e. from the time "the snapshot was taken", by more than a few 

days, especially for satellites with a low orbit like earth observation satellites (see e.g. 

Wikipedia - Two-line element set). 

The NORAD TLEs, which GAFmap® uses by default, are continuously updated (usually several 

times a day) and the orbit propagation is updated accordingly. Note, however, that for this, 

the cache may have to be deleted. For more information, see chapter 5.1.  

 

https://celestrak.org/
https://en.wikipedia.org/wiki/Orbital_elements
https://en.wikipedia.org/wiki/Two-line_element_set
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4 Satellite Orbit Propagation Toolbar 

4.1 Add SOP Target Layer 

[Menu Extras > Extensions > Satellite Orbit Propagation] 

In GAFmap: Toolbar Satellite Orbit Propagation  

 With Add SOP Target Layer you can start the satellite orbit propagation for a specific tar-

get point on earth. To do this, simply activate the button and click on the desired target in the 

map viewer. A selection panel opens via which you can select the satellites to be queried/ 

predicted: 

 

Figure 3: Select Satellites panel 

Select the desired satellites by checking them individually and/or by using the buttons or 

shortcuts provided for this purpose: 

•  inverts the satellite selection / checks/unchecks the satellites marked in 

the list (highlighted in blue). 

Alternatively, you can select/deselect/invert marked satellites with Insert/Del/Space. 

Satellites can be marked by clicking on the name; multiple marking is possible with Ctrl 

or Shift, Ctrl+A marks all satellites in the list.  
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Click OK to confirm the selection. Under the main group Graphics, a new SOP Target Layer is 

then created, which, in addition to the target point itself, displays the expected overflights/ 

paths of the selected satellites calculated for this target point, and the resulting potential ac-

quisition strips (swaths) covering the target point. 

By default, the prediction for the selected satellites is made for three days ahead, starting 

from the query date. Of the predicted orbits, only those sections are displayed from which the 

satellite can actually "see"/acquire the target point, taking into account the maximum possible 

off-nadir angle. Apart from this, the results are unfiltered.  

For further information on the SOP target layer, see chapter 5.1 et seqq., and for information 

on the prediction and filter settings, see chapter 5.1.11 et seqq.  

As long as the button in the toolbar is activated (framed in blue), each additional click in the 

map viewer creates a new SOP target layer. 

See chapter 3.2, if you receive an error message when creating the SOP target layer. 

Selectable Satellites 

The (standard) satellites listed in the Select Satellites panel are a preselection. If you want to 

query other satellites, you can add these subsequently. In this case, select none or any other 

satellite and then change the satellite selection and/or the data source via the properties of 

the SOP target layer (see chapter 5.1.11.1.1).  

If you confirm an empty satellite selection or if the TLEs on which the prediction is based can-

not be retrieved (see chapter 3.2), an empty SOP target layer is created (i.e. the layer then 

only contains the target point, but no satellites). However, satellites can be added to the layer 

subsequently (see chapter 5.1.11.1.1). 

The list of standard satellites offered in the Select Satellites panel can be expanded to include 

custom ones. For more information, see chapter 5.1.11.1.1. 

Adding the SOP Target Point in the 3D Viewer 

[Menu Extras > Extensions > 3D Viewer] 

You can also add the SOP target layer in the 3D Viewer. Note, however, that in 3D the points 

can only be placed on a surface, i.e. on DEMs, 3D models, three-dimensional graphic elements, 

(extruded) features, etc., and not into "empty space". If there is no 3D dataset on the screen 

at the clicked position, no point is created. 
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4.2 Add Day/Night Layer 

[Menu Extras > Extensions > Satellite Orbit Propagation] 

In GAFmap: Toolbar Satellite Orbit Propagation  

Add Day/Night Layer lets you create a new day/night layer. For this, simply click the button. 

The command is then directly executed and a new day/night layer is added under the main 

group Graphics. 

For more information on the day/night layer, see chapter 5.2. 
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5 SOP Layer in the TOC 

5.1 SOP Target Layer   

 The SOP Target Layer is a special graphics element in GAFmap® that 

is played out as result of the satellite orbit propagation. 

Each SOP target layer contains (at the top level) the target point to which the prediction re-

lates, and below it all queried satellites: 

 

Figure 4: SOP target layer in the TOC (left) and visualization in the map viewer (right) 

You can activate/deactivate the queried satellites individually by checking/unchecking them 

in the TOC; the corresponding paths are then shown/hidden accordingly in the map viewer, 

and also only activated satellites are displayed in the point and swath table (see chapter 5.1.5 

and 5.1.6). 

By default, only paths or sections of paths are displayed from which the satellite can actually 

"see"/acquire the target point, taking into account the maximum possible off-nadir angle. This 

option can be deactivated in the properties of the SOP target layer (see chapter 5.1.11.3). 

Please note the update behavior of the SOP target layer (see below). 
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Sub-Satellite Point, Swath Area, and (Potential) Coverage 

The predicted overflights/paths of a satellite are displayed as a series of Sub-Satellite Points 

with a specific (temporal) distance. The points describe the satellite's track on the ground; 

above them the satellite is at its zenith. Relevant information about the satellite (name, 

position, resolution, etc.), the geometric relation between the satellite and the target point 

(distance, viewing direction, etc.), and the time at which the satellite is to be expected at this 

position can be taken from the point table (see chapter 5.1.5). The density of the orbit points 

depends on the selected Time Step (see chapter 5.1.11.1). 

By default, a Swath area is displayed for each path. It depicts an imagery that the satellite 

could theoretically (!) acquire on this path if the sensor tilts towards the target point at the 

point of closest approach in the best possible way.  

The (approximated) rectangle with which the possible acquisition is indicated is created in 

such a way that the target is as central as possible. The width is fixed and results from the 

satellite's maximum field of view (FOV; see chapter 5.1.11.1.1), the Swath Length and Swath 

Direction can be customized in the target point properties (see chapter 5.1.11.1). In the case 

of non-tilting sensors (i.e. those with Max. Off Nadir Angle = 0), the swath area is always a-

ligned along the path. 

 

Figure 5: SOP target layer, example of a swath of a path. The (foot) point shown on the path (cyan) marks the 
point of closest approach of the satellite to the target point (green). 
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If a path is interrupted, e.g. because some sub-satellite points are filtered out (see chapter 

5.1.11.3), an individual swath area is created for each section. 

If you select a swath area (see below), the point of closest approach of the satellite to the 

target point, on which the calculation of the swath geometry is based, is displayed on the 

associated path. Relevant information about the satellite, the geometric relation between the 

satellite at the point of closest approach and the target point, and the time at which the 

satellite is to be expected at this point can be taken from the swath table (see chapter 5.1.6).  

Via the properties of the SOP target layer (see chapter 5.1.11.1) you can hide/show the swath 

areas; alternatively or additionally you can show the coverage area and/or the potential 

coverage: 

The Coverage Area shows the entire possible viewing area of the satellite at a specific position 

(Instantaneous Access Area). It depends on a sensor's maximum possible off-nadir angle (see 

chapter 5.1.11.1.1) and its height. If enabled, the coverage area is displayed around sub-sa-

tellite points as soon as they are selected. It indicates the area that the satellite could theo-

retically cover from this position, utilizing the maximum off-nadir angle in each direction: 

 

Figure 6: SOP target layer, visualization of the satellite's coverage/viewing area at a selected sub-satellite point 

The Potential Coverage also shows the entire possible viewing area of the satellite, but not 

per sub-satellite point, but per path. If enabled, a polygon is displayed along each path. It 
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marks the lateral limit of the potential viewing area, i.e. the visible area when the satellite is 

at maximum roll (= maximum off-nadir perpendicular to the path) during its flight:  

 

Figure 7: SOP target layer, visualization of the potential coverage/viewing area of a path 

Note that swath, coverage area, and potential coverage are only applicable for earth obser-

vation satellites and are therefore not shown for satellites of the type Navigation (see chapter 

5.1.11.1.1). 

Adjusting the Query  

Via the properties of the SOP target layer, you can always extend or reduce the selection of 

the queried satellites, adjust the forecast parameters, and/or filter the results (see chapter 

5.1.11 et seqq.). The position of the target point can also be changed subsequently, e.g. using 

the Graphics Edit tool (see GAFmap® Manual, chapter 4.9.1). The query is then adjusted accor-

dingly. 

Please also note the update behavior of the SOP target layer (see below). 

Selecting Elements of the SOP Target Layer 

The Target Point can be selected by clicking on the SOP target layer in the TOC (at top level, 

not satellite level) or in the map viewer using the Graphics Edit tool (see GAFmap® Manual, 

chapter 4.9.1). The Sub-Satellite Points can only be selected via the point table, the polygons 
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with which the Swaths and potential coverages are displayed only via the swath table (see 

chapter 5.1.5 and 5.1.6). However, the attributes of individual sub-satellite points can be 

queried directly in the map viewer using the Identify tool (see chapter 5.1.5). 

Adjusting the Symbology 

The symbology (= rendering options) of the Target Point can be adjusted directly via the 

properties of the SOP target layer (see chapter 5.1.11), the symbology of the Sub-Satellite 

Points and Swaths for the individual satellites via the Satellites dialog (see chapter 5.1.11.1.1). 

The potential coverage is always displayed with the same symbology as the swaths. 

Context Menu 

A right-click on a selected SOP target layer in the TOC (at top level, i.e. on the target point, not 

at satellite level) or in the map viewer with the Graphics Edit tool (see GAFmap® Manual, 

chapter 4.9.1) takes you to its context menu. Via this context menu you can e.g. 

• zoom to the full layer extent, 

• export the layer / save the layer as GPGK, 

• open the point or swath table, 

• show a sky plot, 

• call-up the properties, etc. 

All functions/commands available in the context menu of the SOP target layer are described 

in the following chapters (see chapter 5.1.1 et seqq.). For information on the (layer-indepen-

dent) commands/functions that are available when you open the context menu for multiple 

selected graphics or layers, see GAFmap® Manual, chapter 5.2.1 et seqq. 

Exporting the SOP Target Layer / Converting the SOP Target Layer into a Vector Dataset  

The SOP target layer is a GAFmap®-specific graphics element. Like all graphics, it is saved 

directly in the project (*.xmp) and not, for example, as a separate dataset (see also GAFmap® 

Manual, chapter 5.2). If you want to save an SOP target layer independently of the project 

and/or convert it into a (non-GAFmap®-specific) vector dataset, you can save it as vector file 

in the OGC-compliant GeoPackage (*.gpkg) format (see chapter 5.1.10). All exported elements 

of the SOP target layer are then available as features in the vector dataset (including, for ex-

ample, the coverage areas). 
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Timeliness of the Forecast / Update Behavior 

The satellite orbit propagation is calculated on the basis of TLEs (see chapter 3.2), which are 

queried directly from a TLE URL (see chapter 5.1.11.1.1). Each TLE source is queried once per 

GAFmap® session (= start of a GAFmap® instance); after that, cached TLEs are used for the 

calculation of the orbits. As the NORAD TLEs provided by CelesTrak are usually updated several 

times a day, it may be advisable to delete the cache via the context menu during long 

GAFmap® sessions (i.e. if GAFmap® remains open for a long time) and thus update the data 

basis (see chapter 5.1.9). After six hours or if you restart GAFmap®, the cache is automatically 

deleted. 

If you want to "freeze" the forecast for a certain period of time, you can, for example, save 

the used TLEs locally as TXT file and use this as data source (see chapter 5.1.11.1.1) or save 

the SOP target layer as GPKG (see chapter 5.1.10). 

 

5.1.1 Zoom to Layer 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

 Zoom to Layer zooms the map to the extent of the layer currently selected in the TOC. 

For more information, see GAFmap® Manual, chapter 5.2.1.1. 

Note that the polygons that indicate the potential coverage (see chapter 5.1.11.1) are not 

taken into account. 

 

5.1.2 Remove 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

 Remove removes the currently selected layer from the TOC/project. The process is only 

completed if it is confirmed in the following dialog. For more information, see GAFmap® 

Manual, chapter 5.2.1.2. 

In the case of the SOP target layer, the command always refers to the target layer as a whole. 

Individual satellites can be removed via the properties of the SOP target layer (see chapter 

5.1.11.1.1). 
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5.1.3 Move to Top/Bottom 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

 Move to Top/Bottom moves the SOP target layer within the main group Graphics in 

the TOC to the top/bottom.  

For more information, see GAFmap® Manual, chapter 5.2.1.3. 

 

5.1.4 Export 

[Menu Extras > Extensions > Specific Workflows > Graphics from Geometry String] (for Export as 
Geometry String) 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

  Export > To XGL lets you save the SOP target layer in the GAFmap®-specific, XML-based 

format *.xgl, i.e. as an "original GAFmap® graphic" with all its properties (see also GAFmap® 

Manual, chapter 5.2.1.9). The XGL can always be reloaded in GAFmap®, regardless of the pro-

ject, e.g. via the context menu of a graphics group with Import from XGL (see GAFmap® Manu-

al, chapter 5.2.1.10) or by drag and drop from the file browser. It cannot be read with other 

software.  

When importing/reloading the XGL, the SOP target layer is restored exactly as exported. 

However, please note the update behavior of the SOP target layer (see chapter 3.3). 

If you export the SOP target layer as a Geometry String, the target point (and only the target 

point!) is output as a simple point coordinate list in the selected format (WKT, JSON, or GML). 

For more information, see GAFmap manual, chapter 5.2.1.9.3. 

Tips and notes: 

• You can save the SOP target layer as GPKG if you want to convert it into a GAFmap® 

independent vector dataset and/or "freeze" the forecast (see chapter 5.1.10). 
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5.1.5 Show Point Table 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

For more information on Sub-Satellite Points see chapter 5.1. 

Show Point Table opens the attribute table of the sub-satellite points. It stores various addi-

tional information for each point, e.g. the satellite concerned, the predicted position and the 

time at which the satellite is to be expected there, as well as further information on the satel-

lite and the geometric relation between satellite and target point (distance, (viewing) angle, 

resolution, etc.): 

 

Figure 8: SOP Target Layer - Point Table 

See below for list of all attributes. 

The structure and functionality of the table largely correspond to that of a (vector layer's) 

attribute table. For information on this, e.g. on the two display modes All/Selected, on sorting, 

selecting, and highlighting rows etc., see GAFmap® Manual, chapter 5.4.1. However, please 

note the following characteristics: 

Contained Sub-Satellite Points / Filter Table by Satellites 

The table only shows the sub-satellite points of satellites that are activated (checked) in the 

TOC. This means that checking/unchecking satellites in the TOC not only controls their visibility 

in the map viewer, but also filters the point table. 
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Selecting/Highlighting Sub-Satellite Points 

The sub-satellite points can only be selected via the point table, e.g. by clicking on the corre-

sponding row header in display mode All. The selected row is then highlighted in blue in the 

table and the associated point geometry is marked in the map viewer with the set selection 

color (cyan by default). 

In display mode Selected, you can create a sub-selection of selected points in the same way. 

Sub-selected points are highlighted in green in the table and the associated point geometry is 

marked in the map viewer with the set highlight color (yellow-green by default). 

 Use the Select tool at the bottom left of the table if you want to select certain points in 

the map viewer: 

 

Figure 9: Selecting sub-satellite points in the map viewer with the Select tool 

If you hold down the Ctrl key while selecting features, you can add features to an existing 

selection or reduce it by re-selecting already selected features. If you additionally hold down 

the Shift key, the selection is only extended but not reduced (if features are re-selected), if 

you only hold the Shift key, the selection is only reduced. 

You cannot select sub-satellite points with e.g. the Select Features tool or the Graphics Edit 

tool.  

 You can always clear a sub-satellite point selection with the Clear Selection button at the 

bottom left of the table or by clicking anywhere off a a sub-satellite point into the map viewer 

with the Select tool. In Selected mode, clicking the Clear Selection button clears a sub-selec-

tion / highlighting but not the selection. 

Querying Sub-Satellite Points in the Map Viewer 

In the map viewer, you can query the attributes of sub-satellite points with the Identify tool 

in the main toolbar: 
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Figure 10: Querying sub-satellite points in the map viewer with the Identify tool 

For more information on the Identify tool, see GAFmap® Manual, chapter 4.1.14. 

Further Functions under Options / in the Row Context Menu 

Under Options in the footer of the table, you can find various further functions, e.g. for ex-

porting and selecting sub-satellite points or for visualizing satellite positions or orbits. They 

are explained in the following chapters. 

Alternatively, these functions can be called up via a context menu, which can be accessed by 

right-clicking on the row header of one or multiple selected or highlighted rows.  
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Figure 11: (Row) Context Menu in the Point Table 

In each case, only those commands that are applicable to the current (sub)selection are active. 

Sub-Satellite Point Attributes 

The following information is stored in the table for each sub-satellite point: 

• Satellite: the name of the associated satellite according to the TLE (i.e. the "satellite 

name"; see chapter 5.1.11.1.1). Please note that only sub-satellite points of satellites 

that are activated in the TOC are displayed in the table (see above). 

• Time_UTC: the time at which the satellite is to be expected at the position [Lon]/[Lat] 

(Date/Time in UTC).  

• Lon/Lat/Height_km: the predicted position of the satellite at time [Time_UTC] (longi-

tude/latitude in degrees and ellipsoidal height in kilometers). 

• SphericalHeight_km: the predicted spherical height of the satellite at time [Time_UTC] 

(height relative to the equator radius of 6378 km in kilometers). 

• Heading: the predicted heading of the satellite relative to the target point (geographi-

cal angle in degrees, i.e. 0 means the satellite moves north, 90 east, etc.). 

• OffNadir: the angle by which the sensor must tilt at the predicted position so that it 

can "see"/acquire the target point (off-nadir in degrees). 

• Roll: the angle by which the sensor must roll (= tilt perpendicular to the flight path) at 

the predicted position so that it can "see"/acquire the target point (in degrees; 0 = 

vertically downwards; 45/-45 = rolled 45° to the left/right in the direction of flight etc.). 

• Pitch: the angle by which the sensor must pitch (= tilt along to the flight path) at the 

predicted position so that it can "see"/acquire the target point (in degrees 0 = vertically 

downwards; 45/-45 = pitched 45° backwards/forwards in the direction of flight etc.). 



GAFmap® - Manual Satellite Orbit Propagation   

  20 

• GSD_m (Ground Sampling Distance): the calculated resolution at the target point (in 

meters). 

• SatAz: the azimuth angle (i.e. the cardinal direction) of the satellite at the predicted 

position relative to the target point (geographical angle in degrees, i.e. 0 means the 

satellite is north, 90 east, etc.). 

• SatEl: the elevation of the satellite at the predicted position relative to the target point 

(horizontal angle in degrees, i.e. 0 means the satellite is on the horizon, 90 it is at the 

zenith). 

• SatRange_km: the distance between target point and satellite at the predicted posi-

tion (in kilometers). 

• Obstructed: indicates whether the target point is visible from the predicted position 

of the satellite (False) or whether the view to the target point is obscured by the terrain 

or the surface structure of the earth (True). For more information on this "DEM ob-

struction", see chapter 5.1.7. 

The weather (i.e. cloud cover) is not included in the calculation. 

For performance reasons, the calculation is only performed when the information is 

actually needed, i.e. the values True or False are only shown if Filter by Obstruction, 

Filter by Shadow, and/or Compute Obstruction and Shadows is set to On in the filter 

properties; otherwise, the column is empty. 

• SunAz: the azimuth angle (i.e. the cardinal direction) of the sun at [Time_UTC] relative 

to the target point (geographical angle in degrees, i.e. 0 means the sun is north, 90 

east, etc.). 

• SunEl: the elevation of the sun at [Time_UTC] relative to the target point (horizontal 

angle in degrees, i.e. 0 means the sun is on the horizon, 90 it is at the zenith). 

• InShadow: indicates whether the target point is in (sun) shadow (True) or not (False) 

at the time [Time_UTC]. If it is night at the target point at the time [Time_UTC], i.e. the 

sun is below the horizon, "in shadow" always applies . 

The surface structure of the earth can only be taken into account for the shadow 

calculation if a suitable DEM is loaded and tagged as such (see GAFmap® Manual, chap-

ter 4.8.5). Otherwise, only the information dark/night (True) and light/day (False) can 

be taken from the column. 

The weather (i.e. cloud shadow) is not included in the calculation. 

For performance reasons, the calculation is only performed when the information is 

actually needed, i.e. the values True or False are only shown if Filter by Obstruction, 

Filter by Shadow, and/or Compute Obstruction and Shadows is set to On in the filter 

properties; otherwise, the column is empty. 
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• CloudCover: the cloud cover [%] to be expected at the target point. Per path, only one 

value is determined, always at time [Time_UTC] at the point of the closest approach 

(see also chapter 5.1.6). 

The forecast is based on the 5 Day Forecast OpenWeatherMap (see GAFmap® Manual, 

chapter 4.7 and/or https://openweathermap.org/). From the three-hour samples, the 

nearest neighbor is returned. If there are no samples within six hours, e.g. because the 

service is unavailable or because the queried time is in the past or more than five days 

ahead, -9999 is returned. 

The weather forecast is cached for three hours, i.e. it is only updated after three hours. 

(Exception: If an error occurs during the query, e.g. during the web request, the fore-

cast, which may then be incomplete, is only cached for six minutes). If needed, the 

cache can always be deleted manually via the SOP target layer's context menu (see 

chapter 5.1.9). 

Shortcuts, Key Commands, etc.: 

• Ctrl when selecting with the Select tool: add selection to current selection. Already 

selected features are deselected when they are selected twice. 

• Shift when selecting with the Select tool: Selected features are deselected when they 

are selected twice. Other features are not added to the current selection. 

• Ctrl + Shift when selecting with the Select tool: add selection to current selection. Se-

lected features are not deselected when they are selected twice. 

 

5.1.5.1 Save Selected to GPKG 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if at least one point is selected or highlighted in the table 

Save Selected to GPKG saves the points selected or highlighted in the table as a vector dataset 

in GeoPackage (*.gpkg) format. The created GeoPackage then contains (in addition to the 

target point / "Target") a point feature table "Points" with the selected sub-satellite points 

including all their attributes. This way you can, for example, permanently save a certain point 

selection. 

A file browser opens. Enter the output directory and file name for the *.gpkg file and confirm 

with Save or click Cancel to return to the table without any further action. 

For more information on saving the SOP target layer as GPKG, see chapter 5.1.10. 

https://openweathermap.org/
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Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

 

5.1.5.2 Show Sky Plot for Selected 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if at least one point is selected or highlighted in the table 

Show Sky Plot for Selected opens a sky plot fir the points selected or highlighted in the table.  

For more information on the Sky Plot, see chapter 5.1.7. 

Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

 

5.1.5.3 Select All Points from this Path 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if a single point is selected or highlighted in the table 

Select All Points from this Path selects/highlights all point in the table that are of the same 

path as the currently selected/highlighted one.  

Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 
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5.1.5.4 Restrict Time to this Path 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if a single point is selected or highlighted in the table 

Restrict Time to this Path lets you restrict the queried time range so that it corresponds 

exactly to the period of the path to which the selected or highlighted point belongs. In the 

properties of the SOP target layer (see chapter 5.1.11.3), Time Range and Start/End Date are 

then (re)set accordingly and the changed filter is applied directly. 

Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

 

5.1.5.5 Set Viewshed for Satellite Position 

[Menu Extras > Extensions > Data Analysis > Viewshed Visualization] and [Menu Extras > Extensions > 
Graphics Editing > Basic Graphics Edit Tools] 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if a single point is selected or highlighted in the table and only useful if a suitable 

DEM is loaded 

Set Viewshed for Satellite Position lets you display the visibility of the terrain from the selec-

ted satellite position in the map viewer. This helps you to evaluate which areas within the 

target area are actually visible from the satellite and which are obscured by a view obstruction 

resulting from the height structure of the earth's surface (e.g. terrain, vegetation, buildings, 

etc.). 

The analysis is particularly useful if the visibility of the exact target point is relevant, the earth's 

surface has significant height differences (especially in the target area), and/or the viewing 

angle of the satellite is flat.  

 If you execute the command, a new viewshed point (VSP) is created at the satellite's posi-

tion at the selected or highlighted sub-satellite point and the Enable/Disable Viewshed button 

in the Map Viewer toolbar is activated. All areas that are visible from the satellite are then 

colored green in the map viewer, and areas that are not visible are colored red: 
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Figure 12: Set Viewshed for Satellite Position, example for two different satellite positions 

 You can always hide the viewshed again by deactivating the corresponding button in the 

Map Viewer toolbar and show it again by re-activating the button. 

The created viewshed point (VSP) is added to the TOC under Graphics, named according to 

satellite and date/time, e.g.: 

 

The viewshed is only created if the VSP is activated, i.e. checked in the TOC. If other VSPs are 

checked in the TOC when you execute the Set Viewshed for Satellite Position command, these 

are automatically deactivated. 
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Prerequisite / Method 

The viewshed is based on the background DEM, i.e. it can only be calculated if at least one 

digital elevation model (DEM) is loaded and marked as such (see GAFmap® Manual, chapter 

3.5.1.1). Areas that are not covered by the background DEM are not included in the analysis 

and are always displayed as "not visible". 

For a usable result, at least the direct surroundings of the target point or the target area should 

be covered by a surface model with suitable accuracy. The - possibly very large - area between 

the VSP and the target point/area does not have to be covered by the background DEM. Note, 

however, that uncovered terrain is not included in the calculation. Depending on the situation, 

this can make the result of the analysis useless, e.g. if this area contains very high mountains 

and the satellite is close to the horizon. Therefore, with a flat viewing angle, a crude DEM 

should be loaded at least for very high areas close to the target area. 

The curvature of the earth is precisely taken into account for the calculation of the viewshed; 

it is based on the WGS84 ellipsoid. 

For more detailed information on the viewshed, e.g. on VSPs, method, accuracy, and perfor-

mance, see GAFmap® Manual, chapter 4.8.6. 

Viewshed in 3D 

[Menu Extras > Extensions > 3D Viewer] 

The viewshed can also be enabled in 3D, but due to the large distance between the VSP and 

the target point it does not provide a reliable result in 3D, mainly because the curvature of the 

earth is not taken into account there. However, if you want to analyze the visibility of the 

target point in 3D, you can directly adopt the viewing position of the satellite instead, i.e. you 

can align the 3D view so that it corresponds to the "satellite's view" on the target point (see 

chapter 5.1.5.9 or 5.1.5.7). 

If you actually want to see the result of the viewshed in the 3D viewer, you can enable it in 2D 

(see above), export the map viewer with Export Map (see GAFmap® Manual, chapter 4.8.12), 

and then place the exported raster as a texture on the DEM in 3D (see GAFmap® 3D Viewer 

Manual, chapter 2.3.3). 
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Tips and notes: 

• Alternatively, you can refer to the Visibility with DEM Obstructions included in the sky 

plot to see from which satellite positions the target point is actually visible and from 

which it is not (see chapter 5.1.7). 

• If it matters that the exact target point is visible from the satellite, you can also filter 

the sub-satellite points by Viewshed (see chapter 5.1.11.3). 

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

 

5.1.5.6 Set Lighting 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if a single point is selected or highlighted in the table 

Set Lighting adjusts the Lighting Direction in the Map properties so that it matches the posi-

tion of the sun at the time [Time_UTC] of the selected or highlighted sub-satellite point. With 

a suitable DEM, you can then e.g. simulate the shadows cast at the potential acquisition time 

in the map viewer, and thus check whether the target point might be in shadow (see chapter 

5.1.11.3 and/or GAFmap® Manual, chapter 4.8.5), or (with the 3D Viewer extension) simulate 

the lighting situation "on site" in the 3D viewer (see GAFmap® 3D Viewer Manual, chapter 

2.5.1). 

For more information on the lighting direction properties, see the GAFmap® Manual, chapter 

5.1.9.2). 

Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 
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5.1.5.7 Create View Point 

[Menu Extras > Extensions > 3D Viewer] 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if a single point is selected or highlighted in the table and the 3D window is open 

Create View Point creates a new view point that stores/shows the "satellite's view" of the 

target point from the sub-satellite point selected or highlighted in the table. You can then 

simulate the view of the satellite in the 3D viewer by aligning it according to the view point 

(e.g. with the command View from Point in the view point's context menu; see GAFmap® 3D 

Viewer Manual, chapter 2.4.1.2). 

 

Figure 13: View of GeoEye-1 onto GAF (21.10.2023, 10:40:30) 

The 3D coordinate of the view point is not taken directly from the map coordinate of the sub-

satellite point, but is recalculated in the local coordinate system of the 3D viewer, based on 

the angle and distance between the target point and the sensor. As a result, map projection 

distortions are avoided and the curvature of the earth is taken into account. (Note that this 

leads to a slight positional deviation between the view point and the sub-satellite point, but 

ensures that the "satellite's view" is realistically reproduced in 3D.) 

The view point properties (e.g. Pitch, Yaw, and IFOV) are set so that they correspond to the 

"view of the satellite" at the selected sub-satellite point. 
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For more information on View Points and their properties, see GAFmap® 3D Viewer Manual, 

chapter 2.4.1. 

Tips and notes:  

• Please note that the "satellite's view" is no longer realistically reproduced if you change 

the spatial reference of the map after the view point was created!  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

• Alternatively, you can simulate the satellite's view with Align 3D View (see chapter 

5.1.5.9). The 3D view is then aligned directly according to the viewing direction of the 

satellite, but the view is not "saved" as view point.  

 

5.1.5.8 Create Flight Line for Selected 

[Menu Extras > Extensions > 3D Viewer] 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if at least two points are selected or highlighted in the table and the 3D window 

is open 

Create Flight Line for Selected creates a new flight line that follows the satellite's overflight 

for the sub-satellite points selected or highlighted in the table and stores/shows its view of 

the target point. You can then simulate the satellite's view of the target point during the 

overflight by executing the flight in the 3D viewer (e.g. with the command Start Flight in the 

flight line's context menu; see GAFmap® 3D Viewer Manual, chapter 2.4.2.3). 
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Figure 14: Overflight of GeoEye-1 over Munich (23.10.2023, 21:18:40 - 21:21:50; target = GAF) 

In theory, a flight line can be created for any selected sub-satellite points, but a useful/realistic 

result is only achieved for consecutive sub-satellite points from the same path. 

The flight line is created with a flight point for each selected sub-satellite point. The 3D coor-

dinates of the flight points are not taken directly from the map coordinates of the sub-satellite 

points, but are recalculated in the local coordinate system of the 3D viewer, based on the 

angle and distance between the target point and the sensor. As a result, map projection dis-

tortions are avoided and the curvature of the earth is taken into account. (Note that this leads 

to a slight positional deviation between the flight line and the sub-satellite points, but ensures 

that the "satellite's view" is realistically reproduced in 3D.) 

The flight points' properties (e.g. Pitch, Yaw, and IFOV) are set so that they correspond to the 

"view of the satellite" at the corresponding sub-satellite point; between the points, the line is 

interpolated. 

For more information on Flight Lines, Flight Points, and their properties, see GAFmap® 3D 

Viewer Manual, chapter 2.4.2. 

Tips and notes:  

• Please note that the "satellite's view" is no longer realistically reproduced if you change 

the spatial reference of the map after the flight line was created!  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 
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• Alternatively, you can simulate the satellite's view with Animate Flyover for Selected 

(see chapter 5.1.5.10). In the 3D viewer, the flight is then directly executed, but the 

flight is not "saved" as flight line.  

 

5.1.5.9 Align 3D View 

[Menu Extras > Extensions > 3D Viewer] 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if a single point is selected or highlighted in the table and the 3D window is open 

Align 3D View aligns the 3D view so that it corresponds to the "satellite's view" of the target 

point from the sub-satellite point selected or highlighted in the table, i.e. you adopt the exact 

perspective of the satellite in the 3D viewer. The satellite's IFOV is also taken into account (see 

chapter 5.1.11.1.1), i.e. the resolution of the image displayed on the screen also corresponds 

to that of the sensor at the respective position. 

The function basically corresponds to the function Create View Point (see chapter 5.1.5.7), 

with the difference that the 3D view is aligned directly and the view is not "saved" as view 

point. 

Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

 

5.1.5.10 Animate Flyover for Selected 

[Menu Extras > Extensions > 3D Viewer] 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if at least two points are selected or highlighted in the table and the 3D window 

is open 

Animate Flyover for Selected starts a flight animation in the 3D view that follows the flyover 

of the satellite for the sub-satellite points selected or highlighted in the table and shows its 

view of the target point. The satellite's IFOV is also taken into account (see chapter 5.1.11.1.1), 

i.e. the resolution of the image displayed on the screen also corresponds to that of the sensor 

at the respective position. 
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The function basically corresponds to the function Create Flight Line (see chapter 5.1.5.8), 

with the difference that the flight animation is executes directly in the 3D viewer and the flight 

is not "saved" as flight line. 

Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

 

5.1.5.11 Add Selected as Feature  

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Only available if a suitable vector layer is loaded, in edit mode, and selected as target layer 

and at least one point is selected or highlighted in the table 

Add Selected as Feature lets you copy selected or highlighted sub-satellite points into a point 

vector layer. Prerequisite is  

• that the attribute table of the point layer has at least all fields of the point table (addi-

tional fields, e.g. geometry fields, are possible) and  

• that the point layer is in edit mode and selected as target layer (see GAFmap® Manual, 

chapter 4.2.9 et seqq.). 

If these requirements are not met, the command is grayed out. 

If you have saved an SOP target layer or selected sub-satellite points as GPKG (see chapter 

5.1.10 or 5.1.5.1), you can always use this function to add further sub-satellite points to the 

feature table Points, e.g. from other satellites or from a different/newer SOP target layer. 

Tips and notes:  

• This function can also be called via a context menu which can be accessed by right-

clicking on a row header in the table (see chapter 5.1.5). 

• If you use the same function for Swaths (see chapter 5.1.6), the above applies 

analogously. The areas can then only be inserted into a corresponding polygon layer 

(with at least all fields of the swath table). 
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5.1.5.12 Resize Columns 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Show Point Table > Options 

Resize Columns lets lets you adjust the width of all columns in the table at once to fit the 

Content, the Header, or the Content & Header. Alternatively, you can adjust the width of 

individual columns manually directly in the table. 

For more information, see chapter GAFmap® Manual, chapter 5.4.1.22. 

 

5.1.6 Show Swath Table 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

For more information on Swaths see chapter 5.1. 

Show Swath Table opens the attribute table of the swaths. It stores various additional infor-

mation for each swath (or more exactly: for the point of closest approach on the correspon-

ding path), e.g. the satellite concerned, the predicted position and the time at which the satel-

lite is to be expected there, as well as further information on the satellite and the geometric 

relation between satellite and target point (distance, (viewing) angle, resolution, etc.). 

The structure and handling of the table, the displayed attributes, and the functions under 

Options correspond (analogously) to those of the point table (see chapter 5.1.5 et seqq.). If 

functions refer to a specific point (e.g. Create View Point; see chapter 5.1.5.7), they refer here 

to the point of closest approach. 

Note that swath, coverage area, and potential coverage are only applicable for earth obser-

vation satellites and satellites of the type Navigation (see chapter 5.1.11.1.1) are therefore 

not shown in the swath table. 

 

5.1.7 Show Sky Plot 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

A Sky Plot shows the position of satellites (or other objects, e.g. stars) at a certain point in 

time or over a certain period of time from the perspective of a target point in a local, topo-

centric coordinate system. The target point is located in the center; the satellite positions are 

specified relative to it in polar coordinates, according to azimuth and elevation. The azimuth 

describes the cardinal direction in geographical degrees towards north, the elevation the 

(visual) angle between the horizon (0°) and the zenith (90°):  
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Figure 15: Sky Plot - azimuth and elevation 

Show Sky Plot opens a diagram window in which the sky plot for the SOP target layer, i.e. for 

the queried satellites and time range relative to the target point, is shown: 
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Figure 16: Visualization of the satellite orbit propagation for a certain target point in the map (bottom) as sky 
plot (top)  

In the diagram viewer (1) on the right, the sky plot is displayed, i.e. the constellation of the 

queried satellites over the queried time range as seen from the target point. Shown are only 

those sub-satellite points that were displayed in the map viewer (at full layer extent) when 

the Sky Plot was opened, i.e. only those of satellites that were activated (checked) in the TOC 

below the SOP target layer and those that were not filtered out. 

In addition to the satellite positions/oaths, the sky plot also shows the Visibility with DEM 

Obstructions as a blue polygon (see below). 

Via the Table of Content (TOC; 2) on the left, you can control which elements are displayed in 

the sky plot by checking/unchecking the corresponding checkboxes. Via the properties in the 

context menu of the individual elements, you can view and adjust the display options (e.g. the 

symbol or the label). For more information on this and on all the functions available in the 

context menus, see the GAFmap® Manual, chapter 5.2.1 et seqq. 

The following elements are listed in the Sky Plot TOC: 

• The Coordinate Axes  

Here, the following Sky Plot-specific property is available: 

o Automatic Step Size: if On, the step size of the elevation rings in the sky plot is 

determined automatically depending on the zoom level. If Off, you can define a 

fixed Step Size (in degrees). 

• The Sub-Satellite Points  

The point symbol with which the sub-satellite points are displayed by default corres-

ponds to that in the map window.  
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• The Visibility with DEM Obstructions 

• All graphic elements inserted via the toolbar of the Sky Plot window 

Via the toolbar (3) of the diagram window you can 

•   Show/Hide the TOC, 

•        adjust the visible extent in the diagram viewer. Alternatively, 

you can use the common shortcuts to adjust the visible extent (see GAFmap® Manual, 

chapter 4.1.6 et seqq.), 

•   Identify the layers/elements in the diagram viewer (see GAFmap® Manual, chap-

ter 4.1.14), 

•   Export the diagram (see GAFmap® Manual, chapter 4.8.12), 

•           add and edit various graphics (see GAFmap® 

Manual, chapter 4.9.1 et seqq.), or 

•    gradually Undo/Redo all performed actions 

Visibility with DEM Obstructions 

DEM obstructions refer to the view obstruction / shading that results from the height struc-

ture of the earth's surface (here for a satellite), e.g. due to terrain elevations, high buildings, 

etc.. So, the Visibility with DEM Obstructions in the sky plot indicates whether satellites can 

"see"/acquire the target point from a certain position or not: the target is only visible from 

sub-satellite points that lie within the blue polygon. 

The DEM obstructions are calculated on the basis of the background DEM (see GAFmap® Ma-

nual, chapter 3.5.1.1). Thus, in order for the calculation to provide a valid result, at least one 

digital elevation model must be loaded and marked as such, and the DEM must at least cover 

the immediate surroundings of the target point. 

The quality of the calculated visibility mainly depends on the following factors: 

• The quality of the DEM, i.e. the type of DEM (surface model vs. terrain model), hori-

zontal and vertical resolution, timeliness, etc.  

In general, the closer to the target point, the more accurately the DEM should depict 

the earth's surface. For more distant areas, coarser (terrain) models are usually suffi-

cient. 
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• The size of the DEM, as only view obstructions that are actually covered by the DEM 

can be included in the calculation!  

In general, the lower the elevation of the satellite, i.e. the closer to the horizon, the 

greater the impact of (high) view obstructions at greater distances, while with a steep 

viewing angle, more distant areas hardly matter. 

• The general setting Viewshed Quality under menu Extras > Settings > Viewing > View-

shed. The higher the selected quality, the higher is the resolution with which the DEM 

is tapped and the better visual obstacles are "hit", but the slower is the calculation (see 

also GAFmap® Manual, chapter 3.5.1.7). 

If no DEM is available, always the entire sky plot is displayed as "visible". 

Timeline Animation 

If you use the Timeline tool in combination with the SOP target layer / sky plot, a timeline 

animation is played in the diagram viewer. In the sky plot, the sub-satellite points are then 

shown one after the other according to their time stamp (see also chapter 6.1). 

Tips and notes: 

• For general information on digital elevation models / DEMs, see GAFmap® Manual, 

chapter 3.5.1.1 or GAFmap® 3D Viewer Manual, chapter 2.3.1. 

 

5.1.8 Show DOP 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

Only available if the SOP target layer only contains satellites of type = Navigation 

The DOP value (Dilution of Precision) allows an estimation of how well a received constellation 

of navigation satellites at a specific location is suitable for determining the position at the time 

of the measurement.  

The following DOP values can be determined: 

• TDOP (Time DOP): time dilution of precision (time) 

• VDOP (Vertical DOP): vertical dilution of precision (1D) 

• HDOP (Horizontal DOP): horizontal dilution of precision (2D) 

• PDOP (Positional DOP): position dilution of precision (3D) 

• GDOP (Geometric DOP): geometric dilution of precision / overall accuracy (3D & time) 
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To calculate the DOP value, at least four satellites must be received. A value of 1 or less is 

ideal; the further it deviates upwards, the more the measured values scatter / the less suitable 

the satellite constellation is for determining the position. With a value above 10, the measured 

values should be considered untrustworthy (see e.g. Wikipedia - Dilution of Precision (Naviga-

tion)  

Show DOP opens a diagram window with the DOP values for the predicted satellite constel-

lation: 

 

Figure 17: graphical representation of the DOP values in the diagram window 

In the diagram viewer (1) on the right, the number of navigation satellites received over the 

queried time range and the DOP values resulting from the predicted constellation are dis-

played graphically. The calculation is carried out for all possible constellations; always the best 

calculated value is displayed. 

Please note that the DOP values in the diagram are capped at 10 for better visualization/sca-

ling (i.e. values > 10 are set to 10). If no calculation can be performed due to an insufficient 

number of satellites, the value is also set to 10. 

Via the Table of Content (TOC; 2) on the left, you can control which elements are displayed in 

the diagram view by checking/unchecking the corresponding checkboxes. Via the properties 

in the context menu of the individual elements, you can view and adjust the display options 

(e.g. the symbol or the label). For more information on this and on all the functions available 

in the context menus, see the GAFmap® Manual, chapter 5.2.1 et seqq. 

https://en.wikipedia.org/wiki/Dilution_of_precision_(navigation)
https://en.wikipedia.org/wiki/Dilution_of_precision_(navigation)
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The following elements are listed in the diagram TOC: 

• The Coordinate Axes  

For more information on the coordinate axis properties, see GAFmap® Manual, chap-

ter 4.1.15.3. 

• The number of Visible Satellites 

• The DOP values resulting from the best satellite constellation (TDOP, VDOP, HDOP, 

PDOP, and GDOP) 

• All graphic elements inserted via the toolbar of the Sky Plot window. 

Via the toolbar (3) of the diagram window you can 

•   Show/Hide the TOC, 

•        adjust the visible extent in the diagram viewer. Alternatively, 

you can use the common shortcuts to adjust the visible extent (see GAFmap® Manual, 

chapter 4.1.6 et seqq.), 

•  adjust the axis ratio stepwise or fit it to the window, 

•   Identify the layers/elements in the diagram viewer (see GAFmap® Manual, chap-

ter 4.1.14), 

•   Export the diagram (see GAFmap® Manual, chapter 4.8.12), 

•           add and edit various graphics (see GAFmap® 

Manual, chapter 4.9.1 et seqq.), or 

•    gradually Undo/Redo all performed actions 

 

5.1.9 Clear Cache 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

Clear Cache lets you delete the cached TLE information and weather data and thus manually 

initiate the update of the SOP target layer at any time.  

For more information on the update behavior of the SOP target layer, see chapter 5.1. 
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Tips and notes: 

• After six hours, the cache is automatically cleared; the forecast is then updated accor-

dingly as soon as it is recalculated (e.g. when filter settings are changed). 

 

5.1.10 Save to GPKG 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

Save to GPKG saves the SOP target layer in the OGC-compliant vector format GeoPackage 

(*.gpkg), i.e. the GAFmap®-specific graphic element is converted into a vector data set that 

can be read independently of the software. 

The created GeoPackage can include the following feature tables: 

• Target: the Target Point. 

• Points: all currently displayed Sub-Satellite Points with all their attributes. 

• Swaths: all currently displayed Swath areas with all their attributes. 

• CoverageAreas: the polygons with which the Coverage Area is displayed (each with 

the attributes of the associated sub-satellite point) 

• PotentialSwaths: the polygons with which the Potential Coverage is displayed (each 

with satellite and start/end time). 

Please note that only elements that were activated when saving are included. If, for example, 

Show Coverage Area was deactivated (see chapter 5.1.11.1), the CoverageAreas feature table 

is missing etc. The same applies to sub-satellite points of satellites that were unchecked in the 

TOC. 

Please also note that the forecast is "frozen" with the GPKG, i.e. unlike with the original SOP 

target layer (see chapter 5.1), the calculation of the orbits is no longer updated, e.g. if there 

are newer TLEs. However, you can always add selected sub-satellite points or swaths from a 

(newer/different) SOP target layer to the tables Points or Swaths (with Add Selected as 

Feature; see chapter 5.1.5.11 or 5.1.6). 
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5.1.11 Properties  

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer (via right-clickt on the target point, not a satellite!) 

 Under Properties, all basic properties of the (selected) SOP target layer are displayed. In 

the following, only SOP target layer specific properties are explained and those, for which 

special aspects are to be considered. For information on the common graphic properties under 

• Symbology (2D symbology and label style), 

• Text (label text), 

• On Screen Info (layer-dependent text that is only displayed on screen), and 

• 3D Symbology (3D symbology and label style; only available if the 3D window is open) 

see GAFmap® Manual, chapter 5.2.1.13 and (for 3D Symbology) GAFmap® 3D Viewer Manual, 

chapter 5.7.2.1. 

Please note that the properties listed above, e.g. the display properties under Symbology, only 

affect the Target Point. The symbology of the Sub-Satellite Points and Swaths can be adjusted 

in the satellite dialog (see chapter 5.1.11.1.1). 

Shortcuts: 

• Double-click on the layer name in the TOC: open Properties  

 

5.1.11.1 General 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Properties 

The properties under General determine the basic settings for the satellite orbit propagation: 

• Satellites: determines for which satellites the forecast is made.  

The query is initially performed for the satellites selected when creating the SOP target 

layer, using the current NORAD TLEs (or for no satellites at all if none was selected; see 

chapter 4.1). The satellite selection and/or the source TLEs can always be adjusted at 

a later stage. 

 opens the Satellites dialog 

For more information, see chapter 5.1.11.1.1. 

• Time Step [s]: determines the time interval with which the satellite positions are cal-

culated. The following applies: The smaller the value, i.e. the smaller the interval, the 

closer the sub-satellite points (see chapter 5.1), but the longer the calculation time. 
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For more information on Sub-Satellite Points, see chapter 5.1. 

• Min Path Length [s]: determines the minimum duration of the satellite overflight for a 

path to be displayed. If 0 is entered, no minimum length is applied. 

Filtered out sub-satellite points (see chapter 5.1.11.3) are not taken into account. If a 

path is interrupted due to filtered out points, the sections are considered separately. 

• Show Swath: determines if the swath areas are displayed in the map viewer (On) or 

not (Off). 

For more information on Swaths, see chapter 5.1. 

Note that the swaths are only included when saving as GPKG (see chapter 5.1.10) if 

they are activated here. 

• Swath Length [m]: determines the length of the swaths in meters. 

• Manual Swath Direction: if On, you can specify the direction of the swaths manually. 

In that case, enter the desired direction at Swath Direction, in geographical degrees 

towards north (0° = north, 90° = east, etc.). 

If Off, the direction of the swaths always corresponds to the flight direction of the sa-

tellite, i.e. they then run along the associated path. 

For satellites with an Max. Off Nadir Angle of 0, which can only aquire along the path, 

the swath areas are always aligned with the path, irrespective of this property. 

For more information on Swaths, see chapter 5.1. 

• Show Potential Coverage: determines if for each path the potential coverage is dis-

played in the map viewer (On) or not (Off).  

For more information on the Potential Coverage, see chapter 5.1. 

Note that the potential coverage is only included when saving as GPKG (see chapter 

5.1.10) if it is activated here. 

• Show Coverage Area: determines if for each selected sub-satellite point the coverage 

area is displayed in the map viewer (On) or not (Off).  

For more information on Coverage Areas, see chapter 5.1. 

Note that the coverage areas are only included when saving as GPKG (see chapter 

5.1.10) if they are activated here. 

• Selectable: determines whether the SOP target layer can be selected in the map viewer 

with the Graphics Edit Tool (see GAFmap® Manual, chapter 4.9.1) (On) or not (Off). If 

the layer is not selectable, it is marked in the TOC with the corresponding  overlay 

icon. The SOP target layer can always be selected via the TOC, i.e. independently of 

this property. 
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Please note that this property only affects the target point of the SOP target layer. The 

sub-satellite points and swaths can always and only be selected via the point or swath 

table (see chapter 5.1.5 or 5.1.6). 

• Description: here, additional information regarding the SOP target layer can be 

viewed, modified, or added (as a simple string or with HTML syntax).  

 opens the additional information window  

 

5.1.11.1.1 Satellites 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Properties > Satellites 

The  button in the properties behind Satellites or a double-click on a satellite under the SOP 

target layer in the TOC takes you to the Satellites dialog. There, you can always change the 

satellite selection for the orbit propagation and/or the source TLEs for selected satellites. 

 

Figure 18: Satellites dialog 

On the left, the satellites for which the forecast is currently made are listed. Using the buttons 

on the left-hand side, you can always 

  add more (default/predefined) satellites to the list.  

The Selected Satellites panel then opens again (see chapter 4.1). Check the satellite(s) 

you want to add here and confirm with OK. All selected satellites are then added to the 

list. 

  remove selected satellites from the list. 
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  add a custom satellite to the list. All parameters on the right, including the source TLE, 

must then be entered manually. 

  export one or multiple satellites selected in the list as XML. 

  import satellites exported as XML. 

On the right, the properties of the satellite(s) selected in the list on the left are shown. For the 

(default) satellites selectable via the Select Satellite panel, the properties are preset (but can 

still be adjusted if required), for other/custom satellites the parameters must be researched 

and set by yourself: 

General 

• Name: specifies the name of the satellite or group in the TOC. You can specify any 

name. 

• Satellite Name (not relevant for groups): refers to the requested satellite in the TLE 

file. The spelling of the satellite name must exactly match that of the TLE (including 

spaces, hyphens etc.), e.g.  

 

• Type: shows the sensor type of the satellite(s) (optical, radar, navigation…).  

• Is Group: specifies whether it is a single satellite (Off) or a satellite group/constellation 

(On).  

In the case of individual satellites, the TLE file entered at TLE URL is searched for the 

satellite name entered above and only this satellite is queried and returned. For 

groups, all satellites listed in the TLE file are queried and returned. The file should then 

only contain satellites that belong to the group/constellation. Examples of groups are 

navigation satellite constellations or, in the case of optical satellites, the SkySat-C 

constellation. 

• Max. Off Nadir Angle (only relevant for earth observation satellites): specifies the sen-

sor's largest possible tilting angle (off-nadir in degree).  

The entered Max. Off-Nadir angle affects the potential viewing area (Instantaneous 

Access Area) of the satellite, i.e. the coverage area and the potential coverage (see 

chapter 5.1). The further the sensor can tilt, i.e. the greater the angle, the greater the 

coverage. 
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By default, only paths or sections of paths are displayed from which the satellite can 

actually "see"/acquire the target point, taking into account a sensor's off-nadir angle. 

This option can be deactivated in the properties of the SOP target layer (see chapter 

5.1.11.3). 

• Min. Off Nadir Angle (only relevant for radar satellites): specifies the sensor's smallest 

possible tilting angle (off-nadir in degree). 

If a min. off nadir angle is entered, the coverage area per point is not drawn as a circle, 

but as a corresponding "doughnut". In the area of the potential coverage, an entered 

min. off-nadir angle is not shown (see chapter 5.1). 

If a min. off-nadir is specified, paths are interrupted in the direct vicinity of the target 

point. Depending on the specified Min. Path Length (see chapter 5.1.11.1), this may 

lead to previously displayed paths being completely omitted due to a length that is too 

short! 

• FOV (Field of View) (only relevant for earth observation satellites): specifies the sen-

sor's field of view in degrees. The field of view influences how large the section of the 

earth's surface is that the satellite can "see"/acquire. It therefore has a direct effect on 

the swath width (see chapter 5.1). The larger the field of view, the wider the swath. 

• IFOV (Instantaneous Field of View) (only relevant for earth observation satellites): spe-

cifies the sensor's field of view per pixel in degrees. The IFOV determines the spatial 

resolution of the sensor and therefore has a direct effect on the resulting ground samp-

ling distance (GSD). The smaller the IFOV, the higher the spatial resolution. 

• TLE URL: refers to the TLE file on which the satellite orbit propagation is based. Enter 

the path to the desired source file here (URL or file path).  

For more information on TLEs, see chapters 3.2 and 3.3. 

The (default) satellites provided in the Select Satellites panel are a preselection of sa-

tellites from the NORAD TLEs under http://www.celestrak.com/NORAD/elements/. 

You can also always query other satellites from the NORAD TLEs and/or satellites from 

other data sources, e.g. from locally stored and/or historical TLE files. Please note, 

however, that the TLE structure must match that of NORAD. Please also note that the 

above-mentioned properties are only stored for the standard satellites. 

Tip: If the satellite orbit propagation is to be carried out for one of the default satellites, 

but based on a different TLE file, first select it via the Select Satellite panel and then 

adjust the data source; this way, the properties above do not have to be entered 

manually. 

Note the update behavior of the SOP target layer (see chapter 5.1). 

http://www.celestrak.com/NORAD/elements/
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Symbology 

• Point Symbol: determines the symbol used to display the sub-satellite points. 

 opens the Point Symbol dialog (see GAFmap® Manual, chapter 6.1) 

• Line Pen: determines the symbol used to display the outline of the swaths. 

 opens the Line Pen dialog (see GAFmap® Manual, chapter 6.2) 

• Fill Brush: determines how the swath polygons are filled. 

 opens the Fill Symbols dialog (see GAFmap® Manual, chapter 6.3) 

The polygons used to display the potential coverage are always shown with the same 

symbol as the swaths. 

If multiple satellites are selected on the left, only the properties that match for all selected 

satellites are shown on the right. Please note that then the properties of all selected satellites 

are changed if you make any changes. 

When you close the satellite dialog via the X button in the top right corner, the prediction is 

carried out anew, for all satellites listed in the dialog. 

Shortcuts: 

• Double-click on a satellite name in the TOC: open Satellites dialog  

Tips and notes: 

• If you export custom satellites as XML and store this in your user profile (see GAFmap® 

manual, chapter 2.3.3) in a subfolder named SatOrbProp, these satellites will be added 

to the Select Satellites panel and can then be selected as (standard) satellites directly 

when setting the target point. You can store multiple XMLs; all satellites from all XMLs 

will then be loaded. 

 

5.1.11.2 Geometry 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Properties 

The properties under Geometry show/influence the position of the target point: 

• X-/Y-Coordinate: determines the X-/Y-coordinate of the target point in the set map 

coordinate system.  

• Height [m]: determines the height (Z-coordinate) of the target point. 
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• Relative to Ground: if On, the height is measured relative to the ground (i.e. above the 

underlying DEM; see GAFmap® Manual, chapter 3.5.1.1). If Off or if no DEM is defined, 

it is measured in absolute terms (or more exactly: a terrain/DEM height of 0 is used). 

The height of the target point "above sea level" has a minimal effect on the angle bet-

ween the target point and the satellite as well as the distance between the two (i.e. on 

OffNadir, Roll and SatRange_km; see chapter 5.1.5). Especially at very high altitudes, 

a DEM should therefore be loaded or an height entered manually. 

If you want the target point to be visualized in the 3D viewer (see chapter 6.2), its 

height must also be known (for the positioning in space).  

If you change the location of the destination point, the forecast is updated accordingly. 

Tips and notes: 

• If you add the target point in 2D, 0 above ground is entered as Height by default. In 3D, 

the height is taken from the hit (terrain) surface and entered as absolute height. Thus, 

the point always sits exactly on the hit surface. 

 

5.1.11.3 Filter 

In GAFmap: TOC > Graphics > Context Menu SOP Target Layer > Properties 

The properties under Filter let you adjust the time range for the forecast and filter the result. 

Please note that most of the filters are only relevant for earth observation satellites (except, 

for example, the time range). 

• Time Range: determines the period for which the satellite orbit propagation is carried 

out.  

  opens a drop-down list 

Available for selection are Days Ahead or Fixed: 

o Days Ahead: if selected, the forecast period starts from date of the query and is 

made for a certain number of days ahead. The number of days can be specified 

under Number of Days Ahead.  

To prevent the time stamps from shifting continuously when the timeline function 

is used (see chapter 6.1), the forecast always starts at 00:00:00 and runs one day 

longer than the entered number of days ahead. If an exact start/end time is im-

portant, select Fixed. 
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o Fixed: If selected, the forecast is made for a fixed time range, starting with the 

Start Date and ending with the End Date. Date/time [UTC] has to be entered in 

the format yyyy-MM-dd hh:mm:ss. 

  opens a calendar  

Tip: When you select the current day in the calendar for the first time, the time is 

set to 00:00; if you select it again, the current time [UTC] is also adopted. 

Please note the update behavior of the SOP target layer (see chapter 5.1). Also note 

that the accuracy of the prediction decreases the further away the queried period is 

from the "recording date" of the TLE (see chapter 3.3). 

• Min./Max. Heading: defines the minimum and maximum allowed heading of the satel-

lite relative to the target point (geographical angle in degrees, i.e. 0 means the satellite 

moves north, 90 east, etc.). 

• Min./Max. Satellite Azimuth: defines the minimum and maximum allowed azimuth 

angle of the satellite relative to the target point (geographical angle in degrees, i.e. 0 

means the satellite is north, 90 east, etc.). 

• Min./Max. Satellite Elevation: defines the minimum and maximum allowed elevation 

of the satellite relative to the target point (horizontal angle in degrees, i.e. 0 means the 

satellite is on the horizon, 90 it is at the zenith). If an angle of -90 (min) and 90 (max) is 

entered, the whole orbit is displayed. 

• Min./Max. Ground Sampling Distance: defines the minimum or maximum allowed 

ground pixel size (GSD) at the target point (in meters). 

• Min./Max. Sun Azimuth: defines the minimum and maximum allowed azimuth angle 

of the sun relative to the target point (geographical angle in degrees, i.e. 0 means the 

satellite is north, 90 east, etc.). 

• Min./Max. Sun Elevation: defines the minimum and maximum allowed elevation of 

the sun relative to the target point (horizontal angle in degrees, i.e. 0 means the satel-

lite is on the horizon, 90 it is at the zenith). 

• Start/End Time of Day: defines the earliest and latest allowed time of day (time in 

format 00:00:00 in UTC). If the entered start and end times match (e.g. 00:00:00 to 

00:00:00), no time-of-day filter is applied. 

• Use Sensor Off Nadir: if On, the Max./Min. Off Nadir Angle specified for a satellite is 

taken into account (see chapter 5.1.11.1.1). Only paths or sections of paths from which 

the satellite can actually "see"/acquire the target point are then returned. If Off, the 

Max./Min. Off Nadir Angle is not taken into account. 
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• Max. Cloud Cover: defines the maximum allowed expected cloud cover at the target 

point (in percent). The forecast is based on the 5 Day Forecast OpenWeatherMap. For 

more information, see chapter 5.1.5. 

• Filter by Obstruction: if On, sub-satellite points are only displayed if the target point 

can actually be seen/acquired from the predicted position, taking DEM obstructions 

into account. If Off, the points are not filtered by obstruction. 

The DEM obstructions are calculated on the basis of the background DEM and in the 

same way as in the Sky Plot. If no DEM is loaded, all points (that are not otherwise 

filtered out) are considered visible. For more information, see chapter 5.1.7. 

The weather (cloud cover) is not taken into account. 

• Filter by Shadow: if On, sub-satellite points are only displayed if the target point is not 

in (sun) shadow at the predicted time [Time_UTC]. If it is night at the target point at 

the time [Time_UTC], i.e. the sun is below the horizon, "in shadow" always applies. If 

Off, the points are not filtered by shadow. 

The surface structure of the earth can only be taken into account for the shadow 

calculation if a suitable DEM is loaded and tagged as such (see GAFmap® Manual, chap-

ter 4.8.5). Otherwise, it is only filtered by dark/night and light/day. 

The weather (cloud shadow) is not taken into account. 

• Compute Obstruction and Shadows: if On, obstruction and shadows are calculated 

and the result is shown in the point/swath table in the columns [Obstructed] and 

[InShadow] (see chapter 5.1.5), but it is not filtered by this information. Both is calcu-

lated automatically if either Filter by Obstruction or Filter by Shadow is set to On. This 

option is then hidden. 

If none of the three filters mentioned above is set to On, the columns [Obstructed] and 

[InShadow] are empty in the point/swath table. For performance reasons, the calcu-

lation is only carried out if the information is actually required. 

! Note that a path becomes shorter or may even be interrupted if individual sub-satellite 

points are filtered out. Depending on the specified Min. Path Length (see chapter 5.1.11.1), 

this may lead to previously displayed paths being completely omitted due to a length that is 

too short! 
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5.2 Day/Night Layer 

In GAFmap: TOC > Graphics > Context Menu Day/Night Layer 

 The Day/Night Layer is a special graphics element in GAFmap® that shows 

the day/night boundary for a specific time worldwide (or more precisely: the "night area"):  

 

Figure 19: Day/Night Layer (2023-12-13 09:15:00 [UTC]) 

The represented point in time can be specified in the properties of the day/night layer (date/ 

time in UTC; see chapter 5.2.1). 

In a timeline animation, the day/night boundary moves along with the currently displayed 

time stamp (see chapter 6.1). 

Context Menu 

A right-click on a selected day/night layer in the TOC takes you to its context menu. It does not 

contain any day/night layer specific functions. For information on the (layer-independent) 

commands/functions that are available for all graphics, see GAFmap® Manual, chapter 5.3 et 

seqq. 
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Tips and notes: 

• Please note that the day/night layer can only be displayed worldwide if the selected 

map spatial reference (see GAFmap® Manual, chapter 5.1.3) is applicable worldwide 

(so not e.g. for UTM!). 

 

5.2.1 Properties 

In GAFmap: TOC > Graphics > Context Menu Day/Night Layer 

 Under Properties, all basic properties of the (selected) day/night layer are displayed. In 

the following, only day/night layer specific properties are explained and those, for which 

special aspects are to be considered. For information on all other (common graphic) proper-

ties, see GAFmap® Manual, chapter 5.2.1.13. 

General: 

• Date: determines which point in time the day/night boundary represents (date/time 

[UTC] in format yyyy-MM-dd hh:mm:ss).  

  opens a calendar  

Tipp: When you select the current day in the calendar for the first time, the time is set 

to 00:00; if you select it again, the current time [UTC] is also adopted. 

Symbology: 

• Line Pen: determines the symbol used to display the day/night boundary (or more 

precisely: the outline of the "night area"). 

 opens the Line Pen dialog (see GAFmap® Manual, chapter 6.2) 

• Fill Brush: determines how the "night area" is filled. 

 opens the Fill Symbols dialog (see GAFmap® Manual, chapter 6.3) 

Shortcuts: 

• Double-click on the layer name in the TOC: open Properties  
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6 Further Display Options 

6.1 Timeline Animation 

[Menu Extras > Extensions > Data Analysis > Timeline] 

In GAFmap: Toolbar for Layer Effects 

  The Timeline function lets you display data animated in the map viewer with regard to a 

time stamp and/or save the animation as a video. A timeline animation is possible for raster 

and vector layers, but also for SOP Target Layers (see chapter 5.1) and Day/Night Layers (see 

chapter 5.2).  

For more information on the Timeline function, see GAFmap® Manual, chapter 4.5.5. 

The following applies specifically to the SOP target layer and the day/night layer: 

• Unlike raster and vector layers, SOP target layers and day/night layers do not have to 

be made available for the timeline function; they are automatically recognized and (if 

selected) used. 

• If animating an SOP Target Layer, the sub-satellite points are shown one after the other 

in the map viewer, according to their time stamp (i.e. according to [Time_UTC]; see 

chapter 5.1.5). Depending on the setting in the Timeline dialog, the satellites then 

move across the map on their orbit: 

 

Figure 20: Timeline animation SOP target layer (path of Pleiades 1A) 

While the animation is running, swaths and potential coverages are not shown. And, 

analogous to the vector layer/attribute table, only sub-satellite points that are current-

ly visible in the map viewer are visible in the point table. 
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A timeline animation in 3D is not possible for the SOP target layer. However, if you 

want to animate the satellite flyover in 3D, you can, for example, execute it directly or 

create a corresponding flight line (see chapters 5.1.5.10 and 5.1.5.8). 

• The satellite orbit points can also be animated in the Sky Plot (see chapter 5.1.7). The 

satellite then moves across the sky plot accordingly. 

• If animating an Day/Night Layer, the day/night boundary is set during the timeline 

animation in the map viewer according to the current time stamp (i.e. the day/night 

boundary "moves" during the animation according to the current time stamp). 

A timeline animation in 3D is not possible for the day/night layer. However, the lighting 

can be set directly in the 3D viewer so that it reflects the lighting situation at a specific 

time of day (via date/time, see GAFmap® 3D Viewer Manual, chapter 5.1.2.2). 

 

6.2 Visualization in the 3D Viewer 

[Menu Extras > Extensions > 3D Viewer] 

Only available if your GAFmap® license includes the 3D Viewer extension 

If the 3D window is open (see GAFmap® 3D Viewer Manual, chapter 2.1), you can simulate the 

"satellite's view" of the target point from a specific position or when flying over it in 3D. More 

precisely, you can either take the satellite's viewing position at a selected sub-satellite point 

(see chapter 5.1.5.9) or execute a flight animation that follows the satellite's path and reflects 

its view of the target point (see chapter 5.1.5.10). Optionally, you can "save" the viewing 

position as view point (see chapter 5.1.5.7) or the flyover as a flight line (see chapter 5.1.5.8). 

In any case, the IFOV of the satellite is taken into account (see chapter 5.1.11.1.1), i.e. the 

resolution of the image displayed on the screen corresponds to that of the sensor at the res-

pective position. If you want the lighting situation during the view/overflight to be reproduced 

realistically, you can set the lighting in the 3D viewer accordingly (see chapter 5.1.5.6); using 

the corresponding button in the toolbar of the 3D window, you can also activate shadows, for 

example, and thus simulate the shadow cast at the time of the overflight (see GAFmap® 3D 

Viewer Manual, chapter 4.1.5).  

The Target Point can be displayed as a 3D object in the 3D viewer. It is located in 3D space 

using its position coordinates and an absolute or relative height information (see chapter 

5.1.11.2). The visualization options correspond to those of a 3D point (see GAFmap® 3D View-

er Manual, chapter 2.3.2.3).  
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7 Packing Behavior (Pack&Go) 

[Menu Extras > Extensions > Pack&Go] 

In GAFmap: Menu Tools > Pack&Go 

Only relevant if your GAFmap® license includes the Pack&Go extension 

The Pack&Go function lets you prepare GAFmap® projects quickly and easily for further distri-

bution. The data contained in the project, which may be e.g. stored scattered anywhere on 

your computer or centrally on a server, is automatically collected, "packed" into a folder and 

optionally compressed. The project itself and all project-specific settings are directly taken 

over. 

Optionally, a Pack&Go container (CMP) can be output. This is a (closed) container file that 

includes the project and all the data it contains. It can be read (in addition to GAFmap®) with 

the freely available CMP reader GAFmap® Express, i.e. also by users who do not own a 

GAFmap® license (free download at https://gafmap-express.gaf.de/). 

For more information on the Pack&Go function, see the GAFmap® Pack&Go Manual. 

If you pack an SOP project as container (CMP), the following applies to the SOP target layer: 

• By default, the SOP target layer is packed together with the underlying TLEs; the satel-

lites then no longer refer to the original TRL URL (see chapter 5.1.11.1.1), but to 

(copied) TLEs in the container. Optionally, you can pack the layer with Connection Info 

Only; in this case, the connection to the original TRL URL is retained. 

• The time range Days Ahead is always converted into a Fixed time range (see chapter 

5.1.11.1).  

• In GAFmap® Express, the SOP target layer can be visualized and analyzed in the same 

way as in GAFmap® (including 3D visualization if applicable), but the satellite selection, 

filter settings, analysis period, etc. can no longer be changed. Therefore, make sure to 

set the settings as required before packing! 

If you do not pack the SOP project as container, the SOP target layer is adopted one to one. 

Note, however, that the TLE sources are also changed to "packed" TLE files here if the 

Connection Info Only option is enabled (so that the packed project can be used "offline"). 

https://gafmap-express.gaf.de/
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